shim 和 polyfill 的区别

赵金添 | 前端 | 2016-01-07
参考: http://www.cnblogs.com/ziyunfei/archive/2012/09/17/2688829.html http://www.2ality.com/2011/12/shim-vs-polyfill.html https://github.com/Modernizr/Modernizr/wiki/HTML5-Cross-Browser-Polyfills [阅读全文]
ė1541次浏览 60条评论 0

解决:Parameter 'dependency' must be a Dependency

| 前端 | 2016-01-05
使用 webpack-dev-server 命令时报错: Parameter 'dependency' must be a Dependency 解决方法: npm i -g webpack 参考: https://github.com/webpack/extract-text-webpack-plugin/issues/132 [阅读全文]
ė1307次浏览 60条评论 0

webpack 的使用

赵金添 | 前端 | 2016-01-03
webpack是近期最火的一款模块加载器兼打包工具,它能把各种资源,例如JS(含JSX)、coffee、样式(含less/sass)、图片等都作为模块来使用和处理。 我们可以直接使用 require(XXX) 的形式来引入各模块,即使它们可能需要经过编译(比如JSX和sass),但我们无须在上面花费太多心思,因为 webpack 有着各种健全的加载器(loader)在默默处理这些事情。 代 [阅读全文]
ė921次浏览 60条评论 0

提高 svn 的图标刷新速度

赵金添 | 前端 | 2016-01-03
TortoiseSVN -> Settings [阅读全文]
ė900次浏览 60条评论 0

我的 github

赵金添 | 前端 | 2015-10-28
前端兄弟可以 follow 一下我的 github,交流学习。 https://github.com/zhaotoday [阅读全文]
ė964次浏览 60条评论 0

基于 rem 开发移动端响应式页面

赵金添 | 前端 | 2015-10-22
示例代码: 【方法一】纯粹css,支持calc函数的动态计算;不支持的用css媒体查询断点,优雅降级。 http://my.codelab.cn/2015-10-22/app-1.html 【方法二】脚本动态计算 (注意:先把html的fontSize设置为 50px(或者加上媒体查询代码), 避免加载未完成时候样式错乱;) http://my.codelab.cn/2015-10- [阅读全文]
ė1432次浏览 60条评论 0

移动端响应式页面开发,借助 rem(旧)

赵金添 | 前端 | 2015-10-20
具体做法请参考: 基于 css3 rem 单位开发移动端响应式页面 本文为旧笔记 笔记代码: http://my.codelab.cn/2015-10-20/app.html 注意: 设计稿按照宽 640px 设计 (宽 640px * 2 这样做的目的是为了在移动端能高清显示。) 参考: http://www.520ued.com/article/53e98 [阅读全文]
ė934次浏览 60条评论 0

webapp 远程调试

赵金添 | 前端 | 2015-09-24
1. 在安卓手机上安装最新版 chrome 浏览器; 2. 手机连接电脑; 3. 在你的手机里打开"设置"->"开发人员工具"->"USB调试" 打开USB调试; 4. 打开电脑的 chrome,在地址栏输入 chrome://inspect,选中 Discover USB devices 可以检测到你的设备; 5. 打开手机上的 chrome,输入调试网址,也可以通过 inspect 里 [阅读全文]
ė953次浏览 60条评论 0

模拟网速 -- Clumsy

赵金添 | 前端 | 2015-09-24
使用Clumsy,可以添加额外的延迟,减少数据包,控制流速以及操作其他网络条件。 参考:http://blog.csdn.net/iefreer/article/details/12855181 下载:http://jagt.github.io/clumsy/download [阅读全文]
ė866次浏览 60条评论 0

混合应用接口调试 -- genymotion(安卓模拟器)+ fiddler(抓包)

赵金添 | 前端 | 2015-09-17
genymotion:需安装 Oracle VM VirtualBox fiddler:需安装 .netframework 代理设置: http://jingyan.baidu.com/article/c1465413a1e2b00bfdfc4c71.html [阅读全文]
ė1206次浏览 60条评论 0

Ɣ回顶部