composer 的安装及使用

作者:赵金添 分类: 发布于:2016-12-9 22:29 ė2074次浏览 60条评论
1. 下载 Composer-Setup.exe

2. choose the command-line php you want to use,选择 php 安装目录下的 php.exe,比如我装的是 phpstudy(当前 php 版本为 7.0),可以选:D:\phpStudy\php70n\php.exe;

3. 安装过程中可能出现:The openssl extension is missing, which will reduce the security and stability of Composer. If possible you should enable it or recompile php with --with-openssl,找到 php 安装目录下的 php.ini,去掉 extension=php_openssl.dll 这一行开头的注释;

4. Packagist 镜像:打开 CMD,执行:composer config -g repo.packagist composer https://packagist.phpcomposer.com;

参考:
https://packagist.org/
http://docs.phpcomposer.com/00-intro.html
http://pkg.phpcomposer.com/

本文出自 赵金添的前端博客@福州软件外包公司,转载时请注明出处及相应链接。

0
分享本文至:

发表评论

电子邮件地址不会被公开。必填项已用*标注


Ɣ回顶部